论坛风格切换切换到宽版
  • 5456阅读
  • 1回复

[易语言]易语言-截取网页文本中间内容 [复制链接]

上一主题 下一主题
离线骑猪兜风
 

发帖
24
金币
114
威望
54
股份
24
只看楼主 倒序阅读 使用道具 楼主  发表于: 2013-11-15
.版本 2


.子程序 取出文本中间, 文本型
.参数 完整文本, 文本型
.参数 左边文本, 文本型
.参数 右边文本, 文本型
.局部变量 文本左边位置, 整数型
.局部变量 文本右边位置, 整数型
.局部变量 起始取出位置, 整数型
.局部变量 中间文本内容, 文本型


文本左边位置 = 寻找文本 (完整文本, 左边文本, , 假)
文本右边位置 = 寻找文本 (完整文本, 右边文本, , 假)
起始取出位置 = 文本左边位置 + 取文本长度 (左边文本)
中间文本内容 = 取文本中间 (完整文本, 起始取出位置, 文本右边位置 - 起始取出位置)
返回 (中间文本内容)

2条评分好评+2
chongl 好评 +1 谢谢@Thanks! 2013-11-15
it民工 好评 +1 热心回复! 2013-11-15



离线chongl

发帖
54
金币
4361
威望
8631
股份
871
只看该作者 沙发  发表于: 2013-11-15
谢谢@Thanks!
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个